
excel formulas

A forumla is nothing more than an equation that you write up. In Excel a typical formula 
might contain cells, constants, and even functions. Here is an example Excel formula that we 
have labeled for your understanding.

=B3 * 5 / SUM(B4:B7)

• cell(s): B3 and the range of cells from B4:B7
• constant(s): 5
• function(s): SUM()

excel formulas: creating your first formula

This first formula will be as simple as they come and will teach you the basic form of an 
Excel formula. Create a new spreadsheet and then follow these steps:

1. Select cell A1
2. Type the following basic arithmetic formula into cell A1: =1+1

3. Press Enter and notice how cell A1 changes from your formula to the result!

This may seem simple, but there are a some very important things you should get out of 
this example. When you start off a cell entry with the equal sign "=" you are telling Excel that 
you want it to evaluate the following formula.

In our case we had a simple "1+1" we wanted Excel to solve for us. You can do this for 
addition, subtraction, multiplication, division and any other operation you can think of.

Remember, if you do not start your entry with the equal sign, then Excel will not evaluate 
the cell!

using cells to create dynamic formulas

The most powerful aspect of Excel is not the simple calculator abilities we describes in 
our first formula example, but rather the ability to take values from cells to be used in your 
formulas.

Let's set up a basic sales spreadsheet to help explain this topic.

1. In cells A1-D4 enter the following information:



Notice: that cell D2 and D3 are blank, but should contain the amount of money from 
selling 150 candy items and 3 vegetables. By referencing the Quantity and Price cells 
we will be able to do this! Let's begin with Candy.

2. Note:It is very important to follow these steps exactly without interruptions! Select cell 
D2, candy's "revenue", and type the equal sign "=" to begin your formula.

3. Left-click on cell B2, Candy's Quantity and notice your formula is now "=B2"

4. We want to multiply Quanity(B2) by Price(B3) so enter an asterisk (*)

5. Now left-click on Candy's Price (C2)to complete your formula!

6. If your formula looks like ours then press Enter, otherwise you can manually enter the 
formula "=B2*C2". However, we really think it is easier and preferred to click on cells 
to reference them, instead of entering that information manually.

7. After you pressed Enter your Candy Revenue cell should be functioning properly and 
contain the value 75.

8. Using your newly gained knowledge please complete Vegetable's Revenue by 
repeating steps 2-7 for Vegetable



9. Your spreadsheet should now look like this:

10. Cheatsheet: If you are having trouble creating the formula for Vegetable's Revenue it 
is "=B3*C3"

advanced excel formulas: using formulas in formulas

Now that we have created separate revenues for both Candy and Vegetable it would be 
nice to somehow combine these two values to get the Total Revenue. Although both 
Vegetable Revenue and Candy Revenue contain formulas, we can still use these cells as we 
have been doing and add them together to get our total.

1. Select cell D5 (directly below "Total")
2. Type the equal sign "="
3. Left-click cell D2
4. Type the plus sign "+"
5. Left-click cell D3. Cell D5 should now contain this formula "=D2+D3":

6. Press Enter to complete your Total Revenue! 



excel keyboard shortcuts

When you are first getting used to Excel you will probably be focused on just getting your 
task done rather than learning how to work more efficiently. However, when you are ready to 
learn about the Excel keyboard shortcuts this lesson will teach you the most important and 
useful Excel shortcuts currently available.
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The benefits of using a keyboard shortcut are twofold:

• It is quicker to keep your hand on the keyboard then shift from keyboard to mouse to 
keyboard

• You will experience less stress on your muscles if you shift your hands less

We have divided the keyboard shortcuts into related areas. This way you can focus on 
learning a group of shortcuts at a time, rather than all at once!

Shortcut Help: Combination keyboard shortcuts, those that have a plus (i.e. Ctrl + S), 
require that you hold the first key (Control) then press the second key (S) while still holding 
down the first key.

excel shortcuts: files

This small group of shortcuts is useful for opening, closing and saving your Excel 
workbooks.

• Ctrl+S: Save your Excel workbook
• Ctrl+O: Open an existing Excel workbook
• Ctrl+N: Create a new Excel workbook

excel shortcuts: editing

These are common shortcuts you will use to edit your Excel workbook. Our favorite 
shortcut in this list is, quite obviously, Ctrl+Z.

• Ctrl+C: Copy the current selection to the clipboard. After you copy something, you 
can paste it with the paste shortcut.

• Ctrl+V: Paste the current item from the clipboard.
• Ctrl+X: Cut the current selection and place it on the clipboard, which can be pasted. 

The difference between cut and copy is that cut will delete your selection, while copy 
will not.

• Ctrl+Z: Undo your last change. This is can be repeated to remove again and again to 
undo many changes.

• Ctrl+Y: Redo your last Undo. This only is available if you have just issued an Undo 
command.

• Backspace: Deletes the current cell and enters edit mode for that cell. This will only 
delete one cell and not a selection.

• Delete: Deletes the current selection. Use the delete key when you want to delete 
more than one cell at a time.
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excel shortcuts: getting around

These shortcuts will help you move around your Excel workbooks and worksheets with 
great ease!

• Page Up: Move one page up in your worksheet
• Page Down: Move one page down in your worksheet. Note: The number of rows 

moved in both page up and page down depend on how many rows are currently 
displayed. The more rows you have displayed the greater amount the row jump will 
be when you do a page up/down.

• Ctrl+Home: Move to the beginning of your worksheet
• Ctrl+End: Move to the end of your worksheet

• Tab: Move right one column
• Shift+Tab: Move left one column

• Ctrl+Page Up: Go back one worksheet
• Ctrl+Page Down: Go forward one worksheet. Note: If you are not using multiple 

worksheets in your workbook you will probably not use this shortcut!

excel shortcuts: formatting

These shortcuts will help you quickly format your data.

• Ctrl+B: Toggles bold on and off for your selection
• Ctrl+I: Toggles italic on and off for your selection
• Ctrl+U: Toggles underline on and off for your selection

• Ctrl+1: Opens up the Format Cell popup 



excel shortcuts: menu

These shortcuts allow you to active the various options on the menu bar without have to 
mouse-click them. Note: These shortcuts use Alt as their combination key.

• Alt+F: Accesses the File menu
• Alt+E: Accesses the Edit menu
• Alt+V: Accesses the View menu
• Alt+I: Accesses the Insert menu
• Alt+T: Accesses the Tools menu
• Alt+D: Accesses the Data menu
• Alt+W: Accesses the Window menu
• Alt+H: Accesses the Help menu

After you have used one of these shortcuts you can use the arrow keys to navigate the 
menu choices and use the Enter key to select a choice.

excel shortcuts: selecting

These shortcuts help you to quickly select items in your Excel file in various ways.

• Shift+Spacebar: Select the current Row
• Ctrl+Spacebar: Select the current column
• Ctrl+A: Select All, will select everything on the current worksheet. This is most often 

used in conjunction with the copy shortcut.

excel shortcuts: miscellaneous

And the two black sheep of the shortcut essentials:

• F1: Opens up the quick help feature
• Ctrl+P: Print your worksheet



excel sort

Sorting in Excel lets you easily reorder your data based on the type of sorting that you 
choose. This lesson will show you how to do a normal and reverse alphabetical sort, as well 
as descending numerical ordering.
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raw unordered data

Imagine that you were teaching an English class and just collected the homework 
assignment for that day. The papers are in no special order, but you know that Excel can sort 
it all out for you anyways. You plough through the jumble of papers and enter the data into 
Excel, ending up with something that looks like...

With the data enetered you are now ready to begin sorting in Excel.

excel sorting: alphabetical order (ascending)

The most common type of sorting, and one that is applicable to our situation, is 
alphabetical ordering. This kind of ordering places the cells that start with the early letters of 
the alphabet (a, b, c...) at the top and the later letters (t, u, v...) at the bottom of the list.

1. First we need to select all the data so we can begin to sort it. Because each name 
has a corresponding score we need to select both columns to preserve the students' 
correct scores.

2. Left-click and hold on cell A1 then drag down-right to cell B10 to highlight all the data 
for sorting! Your spreadsheet should look like this:

3. Left-click the "sort ascending" button, located near the top, on the shortcut bar (it has 
a blue A on top and a red Z on bottom with a downward pointing arrow). 
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4. Your spreadsheet should now be sorted. 

Notice that your column titles (Name and Score) have not been included for sorting 
because Excel is smart enough to know that you do not want these special cells (A1 and B1) 
included.

reverse alphabetical order (descending)

The steps for reverse alphabetical order are the same as above, except that you need to 
click the "sort descending" button instead.

1. Select the data you wish to sort (left-click in cell A1 and drag down-right to B10)

2. Left-click the "sort descending" button, located near the top, on the shortcut bar (it 
has a red Z on top and a blue A on bottom downward pointing arrow). 



3. Your spreadsheet should now be sorted in reverse alphabetical order. 

numerical ordering

If you wanted to instead sort the homework assignments by highest to lowest score you 
would follow these steps to use Excel's numeric sorting. The only difference between this 
example and our previous examples is which column you start your selection from, so pay 
close attention to the first step!

1. Left-click cell B1 and drag down-left to cell A10 

2. Left-click the "sort descending" button, located near the top, on the shortcut bar (it 
has a red Z on top and a blue A on bottom with a downward pointing arrow). 



3. Your Excel data should now look like: 

Congratulations, you now know how to sort columns of both numbers and words in Excel!

generic formatting in excel

Sometimes you don't have the data set up nice and orderly like our above examples, 
which might make using Excel's quick sort buttons to fall flat on their face when attempting to 
sort your data. If you would like to access Excel's manual, and much more powerful, sorting 
option simply select "Data < Sort..." from the menu bar.

Note: Be sure that you select your data before going to the manual sorting feature. This 
will let Excel know which data you want to sort.



excel - if statement

An If Statement is used in Excel to do certain actions only if something is true. For 
example, you might want to print out the message "We are losing money" if total sales for the 
quarter are below some amount. Otherwise, you'd just want to print out "We're making 
money!"
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The IF function lets you do these kinds of value based decisions. This lesson will show 
you a couple basic examples of how you can make use of the IF function.

excel - if function

The IF function needs to have some sort of comparison to operate properly. A very 
common type of comparison is greater/less than (>/<). These math symbols can be used to 
form logical expressions like "A2 < 40000", which in English means "Cell A2 is less than 
40000".

Now that logical expression can be either true or false and the IF function lets you do 
something for each result. In this little example we will be making our IF function print out 
something our boss might say.

Your excel spreadsheet should look like this:

excel - if function's 3 parts

The IF function has three parts:

1. The comparison you will be doing. We are using A2 < 40000
2. What to do if the If statement is true
3. What to do if the If statement is false

If all that information is confusing to you, don't worry, Excel has a built in wizard to help 
you make your own If functions.

1. Go to the Insert menu and choose Function
2. Select the Logical functions from the drop down selector

3. Choose the IF function and click OK

http://www.tizag.com/about/advertise.php


4.

5. Put "A2<40000" as the logical expression
6. Put "We are losing money?" as the true value
7. Put "We are making money!" as the false value

8. Press OK

Because our sales were only $30,000 the if statement should be printing out "We are 
losing money?"

This isn't good at all, we're going to get fired!

make some accounting adjustments

Let's make some small accounting changes and up that sales figure to $50,000 and see 
what the IF function prints out.

Ah that is much better, now we're making money!

Notice that when the value of A2 was $30,000 it was less than $40,000 and our IF 
function was set to print out "We are losing money?" when A2 was less than 40,0000. 
However, when we changed the value of A2 to $50,000 the IF statement was now false and it 
printed out "We are making money!"



excel - drop down list

Ever wish that you didn't have to type out the same thing over and over again? Well you 
can save time by using Excel's drop down list!
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drop down preparation

Imagine that we are creating an Excel spreadsheet to document our purchases from the 
grocery store. For each purchase we want to mark down thename of the food and the type of 
the food.

The way a drop down list works in Excel is that it takes values from some place on your 
spreadsheet and uses them to populate the options in the list. Lucky for us, the type of food is 
a perfect opportunity to use a drop down list!

In cells A1 through A7 enter the type of food that will be used for the drop down list.

creating a drop down list

Now that we have a source for our drop down list, we can create a begin to create our 
drop down.

1. Select cells D2 though D20 (We will be creating a drown down list for each cell in this 
range) 
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2. Click the Data menu and select Validation
3. Choose List from the Allow drop down menu

4. Click the Source button that appears to the right of the textfield 

5. Select our source cells A1 though A7 

6. Press Enter and Click OK

testing your drop down

All of your cells in the Type column should now have a drop down list. To test to see if 
your drop down works, click on cell D2 and then click on the downward facing arrow and see 
if all the types of food are available.



excel linking

At times you may want to use information that exists in a different Excel file. This use of 
external information is referred to as "linking" in Excel. This lesson will show you the basics of 
creating workbook links in Excel.
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creating two files

This example will require that you create two files link1.xls and link2.xls. Let's start with 
creating link1.xls.

This is a very simple file and only contains the text "this workbook" in cell A1. Save this 
file as link1.xls.

Now let's make link2.xls.

This worksheet only has one data entry in C1 with the value "has a link". Save this file 
as link2.xls in the same directory as link1.xls.

excel linking: the reference

As you can probably tell, we are going to link to the information in our second file so that 
our first file has the line "this workbook has a link". The actual link reference is quite 
complicated looking, so please take your time to understand each component of the Excel 
Link.

There are three major parts that a link must have to be valid:

1. Workbook: This is the filename of your Excel document.
2. Worksheet: This is the worksheet name of your Excel sheet. The default name would 

be Sheet1.
3. Cells: The cell(s) which are going to be linked to.

These three parts combine to make a pretty ugly looking blob of text. Using the general 
terms from above, this is how a generic link would look.

• =[Workbook.xls]Worksheet!Cells

For our example, the Workbook is link2.xls, the Worksheet is Sheet1 and the cell is C1. 
Our link would then be:

1. =[link2.xls]Sheet1!C1
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2. Enter this link into cell C1 of link1.xls and hit Return.

3. Your link1.xls file should now properly link to your second file to display "this 
workbook has a link".



free ms excel viewer

Microsoft software isn't cheap, and Microsoft Excel is no exception. If you only need to 
view and print Excel documents then don't drop hundreds of dollars on MS software!
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Many people already know about Microsoft's free Excel viewer, but it isn't something they 
like to advertise. It has been around in some form or another for almost a decade and the 
recent version is MS Excel Viewer 2003, which is a replacement for all previous iterations.

download your free ms excel viewer!

This link is subject to change, so please Contact Us if it stops working.

Download your FREE Excel 2003 Viewer from microsoft.com.

i already have excel. why is this useful?

If you already purchased Excel, you can still make use out of this free viewer. Do you 
have employees in your company who don't work in Excel, but need to view or print it from 
time to time? Maybe you Excel documents on your company's internet network, but not 
everyone has their own copy of Excel.

http://www.microsoft.com/downloads/details.aspx?familyid=c8378bf4-996c-4569-b547-75edbd03aaf0&displaylang=en
http://www.tizag.com/about/contact.php
http://www.tizag.com/about/advertise.php
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